package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),?\s*\"(\\.|[^\"])+\"\s*:\s*null`)
var str = `{"a": null}
{"a": 123, "b": null}
{"a": 123, "b": null, "c": "foo"}
{"a": 123, "b": null, "c": "foo", "blby\"nazov": false}
{"a": 123, "b": null, "c": "foo", "blby\"nazov\"null hodnotou": null, "d": 1}
{"a": 123, "b": null, "c": "foo{\"x\": null}", "d": 1}
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}