#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[+-]?(?:0|[1-9]\d*)(?:\.\d+)?$"
Local $sString = "VALID" & @CRLF & _
"" & @CRLF & _
"+1" & @CRLF & _
"-1" & @CRLF & _
"1" & @CRLF & _
"" & @CRLF & _
"+1.0" & @CRLF & _
"-1.0" & @CRLF & _
"1.0" & @CRLF & _
"" & @CRLF & _
"+0.01" & @CRLF & _
"-0.01" & @CRLF & _
"0.01" & @CRLF & _
"" & @CRLF & _
"+111.111" & @CRLF & _
"-111.111" & @CRLF & _
"111.111" & @CRLF & _
"" & @CRLF & _
"INVALID" & @CRLF & _
"" & @CRLF & _
"+-0" & @CRLF & _
"00" & @CRLF & _
"01" & @CRLF & _
"1.1.1" & @CRLF & _
"1,0" & @CRLF & _
"abc" & @CRLF & _
"1."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")