using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?(?:0|[1-9]\d*)(?:\.\d+)?$";
string input = @"VALID
+1
-1
1
+1.0
-1.0
1.0
+0.01
-0.01
0.01
+111.111
-111.111
111.111
INVALID
+-0
00
01
1.1.1
1,0
abc
1.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}