import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-]?(?:0|[1-9]\\d*)(?:\\.\\d+)?$";
final String string = "VALID\n\n"
+ "+1\n"
+ "-1\n"
+ "1\n\n"
+ "+1.0\n"
+ "-1.0\n"
+ "1.0\n\n"
+ "+0.01\n"
+ "-0.01\n"
+ "0.01\n\n"
+ "+111.111\n"
+ "-111.111\n"
+ "111.111\n\n"
+ "INVALID\n\n"
+ "+-0\n"
+ "00\n"
+ "01\n"
+ "1.1.1\n"
+ "1,0\n"
+ "abc\n"
+ "1.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}