const regex = /^[+-]?(?:0|[1-9]\d*)(?:\.\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+-]?(?:0|[1-9]\\d*)(?:\\.\\d+)?$', 'gm')
const str = `VALID
+1
-1
1
+1.0
-1.0
1.0
+0.01
-0.01
0.01
+111.111
-111.111
111.111
INVALID
+-0
00
01
1.1.1
1,0
abc
1.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}