import Foundation
let pattern = #"^[+-]?(?:0|[1-9]\d*)(?:\.\d+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
VALID
+1
-1
1
+1.0
-1.0
1.0
+0.01
-0.01
0.01
+111.111
-111.111
111.111
INVALID
+-0
00
01
1.1.1
1,0
abc
1.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)