package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)<(category) name="Content Server Categories:(.+?)">(.+?)</(category)>`)
var str = `<category name="Content Server Categories:FOLDER:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER1:FOLDER2:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER NAME:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER NAME: FOLDER NAME1:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER:test category name">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>`
var substitution = "<$1-$2 name="Content Server Categories:$2">$3</$1-$2>"
fmt.Println(re.ReplaceAllString(str, substitution))
}