const regex = new RegExp('(?s)<(category) name="Content Server Categories:(.+?)">(.+?)</(category)>', 'gm')
const str = `<category name="Content Server Categories:FOLDER:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER1:FOLDER2:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER NAME:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER NAME: FOLDER NAME1:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER:test category name">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>`;
const subst = `<$1-$2 name="Content Server Categories:$2">$3</$1-$2>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);