re = /(?s)<(category) name="Content Server Categories:(.+?)">(.+?)<\/(category)>/m
str = '<category name="Content Server Categories:FOLDER:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER1:FOLDER2:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER NAME:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER NAME: FOLDER NAME1:test category">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>
<category name="Content Server Categories:FOLDER:test category name">
<attribute name="test attribuut"><![CDATA[test]]></attribute>
<attribute name="test attribuut1"><![CDATA[test1]]></attribute>
</category>'
subst = '<$1-$2 name="Content Server Categories:$2">$3</$1-$2>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result