// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?s)<(category) name="Content Server Categories:(.+?)">(.+?)</(category)>"#).unwrap();
let string = "<category name=\"Content Server Categories:FOLDER:test category\">
<attribute name=\"test attribuut\"><![CDATA[test]]></attribute>
<attribute name=\"test attribuut1\"><![CDATA[test1]]></attribute>
</category>
<category name=\"Content Server Categories:FOLDER1:FOLDER2:test category\">
<attribute name=\"test attribuut\"><![CDATA[test]]></attribute>
<attribute name=\"test attribuut1\"><![CDATA[test1]]></attribute>
</category>
<category name=\"Content Server Categories:FOLDER NAME:test category\">
<attribute name=\"test attribuut\"><![CDATA[test]]></attribute>
<attribute name=\"test attribuut1\"><![CDATA[test1]]></attribute>
</category>
<category name=\"Content Server Categories:FOLDER NAME: FOLDER NAME1:test category\">
<attribute name=\"test attribuut\"><![CDATA[test]]></attribute>
<attribute name=\"test attribuut1\"><![CDATA[test1]]></attribute>
</category>
<category name=\"Content Server Categories:FOLDER:test category name\">
<attribute name=\"test attribuut\"><![CDATA[test]]></attribute>
<attribute name=\"test attribuut1\"><![CDATA[test1]]></attribute>
</category>";
let substitution = "<$1-$2 name=\"Content Server Categories:$2\">$3</$1-$2>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}