import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)<(category) name=\"Content Server Categories:(.+?)\">(.+?)</(category)>";
final String string = "<category name=\"Content Server Categories:FOLDER:test category\">\n"
+ " <attribute name=\"test attribuut\"><![CDATA[test]]></attribute>\n"
+ " <attribute name=\"test attribuut1\"><![CDATA[test1]]></attribute>\n"
+ "</category>\n\n"
+ "<category name=\"Content Server Categories:FOLDER1:FOLDER2:test category\">\n"
+ " <attribute name=\"test attribuut\"><![CDATA[test]]></attribute>\n"
+ " <attribute name=\"test attribuut1\"><![CDATA[test1]]></attribute>\n"
+ "</category>\n\n"
+ "<category name=\"Content Server Categories:FOLDER NAME:test category\">\n"
+ " <attribute name=\"test attribuut\"><![CDATA[test]]></attribute>\n"
+ " <attribute name=\"test attribuut1\"><![CDATA[test1]]></attribute>\n"
+ "</category>\n\n"
+ "<category name=\"Content Server Categories:FOLDER NAME: FOLDER NAME1:test category\">\n"
+ " <attribute name=\"test attribuut\"><![CDATA[test]]></attribute>\n"
+ " <attribute name=\"test attribuut1\"><![CDATA[test1]]></attribute>\n"
+ "</category>\n\n"
+ "<category name=\"Content Server Categories:FOLDER:test category name\">\n"
+ " <attribute name=\"test attribuut\"><![CDATA[test]]></attribute>\n"
+ " <attribute name=\"test attribuut1\"><![CDATA[test1]]></attribute>\n"
+ "</category>";
final String subst = "<$1-$2 name=\"Content Server Categories:$2\">$3</$1-$2>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}