# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\s\S]*)\b\d+(?:\.\d+){2,}\s*([\s\S]*)/$1$2/g;t' <<< "Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.
58.0.3029 Copyright 2011 Google Inc."