use strict;
my $str = 'Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.
58.0.3029 Copyright 2011 Google Inc.';
my $regex = qr/([\s\S]*)\b\d+(?:\.\d+){2,}\s*([\s\S]*)/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";