using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\s\S]*)\b\d+(?:\.\d+){2,}\s*([\s\S]*)";
string substitution = @"$1$2";
string input = @"Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.
58.0.3029 Copyright 2011 Google Inc.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}