# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\s\S]*)\b\d+(?:\.\d+){2,}\s*([\s\S]*)"
test_str = ("Microsoft (R) Windows Script Host Version 5.8\n"
"Copyright (C) Microsoft Corporation. All rights reserved.\n\n"
"58.0.3029 Copyright 2011 Google Inc.")
subst = "$1$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.