import Foundation
let pattern = #"([\s\S]*)\b\d+(?:\.\d+){2,}\s*([\s\S]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Microsoft (R) Windows Script Host Version 5.8
Copyright (C) Microsoft Corporation. All rights reserved.
58.0.3029 Copyright 2011 Google Inc.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)