import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<action>My-DATA)\\s+:desc:(?P<desc>.*):?\\s+:priority:(?P<priority>.*):?\\s+:lbl:(?P<lbl>.*):?";
final String string = "My-DATA :desc:I would like to get details from https://mydata.org/this-is-my-data: :priority:3: :lbl:data:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}