import Foundation
let pattern = #"(?P<action>My-DATA)\s+:desc:(?P<desc>.*):?\s+:priority:(?P<priority>.*):?\s+:lbl:(?P<lbl>.*):?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"My-DATA :desc:I would like to get details from https://mydata.org/this-is-my-data: :priority:3: :lbl:data:"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)