const regex = /(?P<action>My-DATA)\s+:desc:(?P<desc>.*):?\s+:priority:(?P<priority>.*):?\s+:lbl:(?P<lbl>.*):?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<action>My-DATA)\\s+:desc:(?P<desc>.*):?\\s+:priority:(?P<priority>.*):?\\s+:lbl:(?P<lbl>.*):?', 'gm')
const str = `My-DATA :desc:I would like to get details from https://mydata.org/this-is-my-data: :priority:3: :lbl:data:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}