re = /(?P<action>My-DATA)\s+:desc:(?P<desc>.*):?\s+:priority:(?P<priority>.*):?\s+:lbl:(?P<lbl>.*):?/m
str = 'My-DATA :desc:I would like to get details from https://mydata.org/this-is-my-data: :priority:3: :lbl:data:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end