// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<action>My-DATA)\s+:desc:(?P<desc>.*):?\s+:priority:(?P<priority>.*):?\s+:lbl:(?P<lbl>.*):?").unwrap();
let string = "My-DATA :desc:I would like to get details from https://mydata.org/this-is-my-data: :priority:3: :lbl:data:";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}