$re = '/(?P<action>My-DATA)\s+:desc:(?P<desc>.*):?\s+:priority:(?P<priority>.*):?\s+:lbl:(?P<lbl>.*):?/m';
$str = 'My-DATA :desc:I would like to get details from https://mydata.org/this-is-my-data: :priority:3: :lbl:data:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);