package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w)\s(\w)`)
var str = `tags:: tree dog book razor`
var substitution = "$1, $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}