import re
regex = re.compile(r"(\w)\s(\w)", flags=re.MULTILINE)
test_str = "tags:: tree dog book razor"
subst = "$1, $2"
result = regex.sub(subst, test_str)
if result:
print(result)