const regex = /(\w)\s(\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w)\\s(\\w)', 'gm')
const str = `tags:: tree dog book razor`;
const subst = `$1, $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);