import Foundation
let pattern = #"(\w)\s(\w)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"tags:: tree dog book razor"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1, $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)