use strict;
my $str = 'tags:: tree dog book razor';
my $regex = qr/(\w)\s(\w)/mp;
my $subst = '$1, $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";