re = /(\w)\s(\w)/m
str = 'tags:: tree dog book razor'
subst = '$1, $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result