using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([0-1]\d|2[0-3]):[0-5]\d)|((1[0-2]:[0-5][0-9])|([1-9]:[0-5][0-9])\s(am|pm))";
string input = @"22:22 am22:33 am
13:22
12:22 am
qwq29:22 pma
a22:22a
2:12 amsad
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}