re = /(([0-1]\d|2[0-3]):[0-5]\d)|((1[0-2]:[0-5][0-9])|([1-9]:[0-5][0-9])\s(am|pm))/m
str = '22:22 am22:33 am
13:22
12:22 am
qwq29:22 pma
a22:22a
2:12 amsad
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end