use strict;
my $str = '22:22 am22:33 am
13:22
12:22 am
qwq29:22 pma
a22:22a
2:12 amsad
';
my $regex = qr/(([0-1]\d|2[0-3]):[0-5]\d)|((1[0-2]:[0-5][0-9])|([1-9]:[0-5][0-9])\s(am|pm))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}