// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([0-1]\d|2[0-3]):[0-5]\d)|((1[0-2]:[0-5][0-9])|([1-9]:[0-5][0-9])\s(am|pm))").unwrap();
let string = "22:22 am22:33 am
13:22
12:22 am
qwq29:22 pma
a22:22a
2:12 amsad
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}