import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([0-1]\\d|2[0-3]):[0-5]\\d)|((1[0-2]:[0-5][0-9])|([1-9]:[0-5][0-9])\\s(am|pm))";
final String string = "22:22 am22:33 am\n"
+ "13:22\n"
+ "12:22 am\n"
+ "qwq29:22 pma\n"
+ "a22:22a\n"
+ "2:12 amsad\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}