import Foundation
let pattern = #"(([0-1]\d|2[0-3]):[0-5]\d)|((1[0-2]:[0-5][0-9])|([1-9]:[0-5][0-9])\s(am|pm))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
22:22 am22:33 am
13:22
12:22 am
qwq29:22 pma
a22:22a
2:12 amsad
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)