#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]\.[a-zA-Z]\.(?:2019|20[2-9][0-9]|2[1-9][0-9]{2}|[3-9][0-9]{3})@uts\.edu\.co$"
Local $sString = "j.g.1999@uts.edu.co" & @CRLF & _
"j.g.2018@uts.edu.co" & @CRLF & _
"j.g.2019@uts.edu.co" & @CRLF & _
"j.g.2020@uts.edu.co" & @CRLF & _
"j.g.2099@uts.edu.co" & @CRLF & _
"j.g.2119@uts.edu.co" & @CRLF & _
"j.g.4904@uts.edu.co"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")