re = /^[a-zA-Z]\.[a-zA-Z]\.(?:2019|20[2-9][0-9]|2[1-9][0-9]{2}|[3-9][0-9]{3})@uts\.edu\.co$/m
str = 'j.g.1999@uts.edu.co
j.g.2018@uts.edu.co
j.g.2019@uts.edu.co
j.g.2020@uts.edu.co
j.g.2099@uts.edu.co
j.g.2119@uts.edu.co
j.g.4904@uts.edu.co'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end