import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z]\\.[a-zA-Z]\\.(?:2019|20[2-9][0-9]|2[1-9][0-9]{2}|[3-9][0-9]{3})@uts\\.edu\\.co$";
final String string = "j.g.1999@uts.edu.co\n"
+ "j.g.2018@uts.edu.co\n"
+ "j.g.2019@uts.edu.co\n"
+ "j.g.2020@uts.edu.co\n"
+ "j.g.2099@uts.edu.co\n"
+ "j.g.2119@uts.edu.co\n"
+ "j.g.4904@uts.edu.co";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}