using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]\.[a-zA-Z]\.(?:2019|20[2-9][0-9]|2[1-9][0-9]{2}|[3-9][0-9]{3})@uts\.edu\.co$";
string input = @"j.g.1999@uts.edu.co
j.g.2018@uts.edu.co
j.g.2019@uts.edu.co
j.g.2020@uts.edu.co
j.g.2099@uts.edu.co
j.g.2119@uts.edu.co
j.g.4904@uts.edu.co";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}