use strict;
my $str = 'j.g.1999@uts.edu.co
j.g.2018@uts.edu.co
j.g.2019@uts.edu.co
j.g.2020@uts.edu.co
j.g.2099@uts.edu.co
j.g.2119@uts.edu.co
j.g.4904@uts.edu.co';
my $regex = qr/^[a-zA-Z]\.[a-zA-Z]\.(?:2019|20[2-9][0-9]|2[1-9][0-9]{2}|[3-9][0-9]{3})@uts\.edu\.co$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}