using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<(/|)(!--|div|span|a|img|p)[^>]*>(\n|)| )";
string substitution = @"";
string input = @"mass <=45 and >=30g
Contrary to <FM>
reading < 2 DAC hours ... reading > 2 DAC hours
Landon <lando@master.lanl.gov>
<!-- this is an html comment -->
<DIV>
<div></div>
<p>
<P>
<SPAN>
<span style=""stuff and yo"">
<a href=""><img src=""https://lanl.com""></a>
Here is: more text";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}