const regex = new RegExp('(<(/|)(!--|div|span|a|img|p)[^>]*>(\\n|)| )', 'gi')
const str = `mass <=45 and >=30g
Contrary to <FM>
reading < 2 DAC hours ... reading > 2 DAC hours
Landon <lando@master.lanl.gov>
<!-- this is an html comment -->
<DIV>
<div></div>
<p>
<P>
<SPAN>
<span style="stuff and yo">
<a href=""><img src="https://lanl.com"></a>
Here is: more text`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);