package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(<(/|)(!--|div|span|a|img|p)[^>]*>(\n|)| )`)
var str = `mass <=45 and >=30g
Contrary to <FM>
reading < 2 DAC hours ... reading > 2 DAC hours
Landon <lando@master.lanl.gov>
<!-- this is an html comment -->
<DIV>
<div></div>
<p>
<P>
<SPAN>
<span style="stuff and yo">
<a href=""><img src="https://lanl.com"></a>
Here is: more text`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}