import re
regex = re.compile(r"(<(/|)(!--|div|span|a|img|p)[^>]*>(\n|)| )", flags=re.IGNORECASE)
test_str = ("mass <=45 and >=30g\n"
"Contrary to <FM>\n"
"reading < 2 DAC hours ... reading > 2 DAC hours\n"
"Landon <lando@master.lanl.gov>\n"
"<!-- this is an html comment -->\n"
"<DIV>\n"
"<div></div>\n"
"<p>\n"
"<P>\n"
"<SPAN>\n"
"<span style=\"stuff and yo\">\n"
"<a href=\"\"><img src=\"https://lanl.com\"></a>\n"
"Here is: more text")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)