#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\/d\/([^\/\\]+)(?:\/|$)"
Local $sString = "https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/edit#gid=123" & @CRLF & _
"" & @CRLF & _
"https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/history/test1#gid=123" & @CRLF & _
"" & @CRLF & _
"https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")