import re
regex = re.compile(r"\/d\/([^\/\\]+)(?:\/|$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/edit#gid=123\n\n"
"https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/history/test1#gid=123\n\n"
"https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")