import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/d\\/([^\\/\\\\]+)(?:\\/|$)";
final String string = "https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/edit#gid=123\n\n"
+ "https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/history/test1#gid=123\n\n"
+ "https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}