// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)\/d\/([^\/\\]+)(?:\/|$)").unwrap();
let string = "https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/edit#gid=123
https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/history/test1#gid=123
https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}