$re = '/\/d\/([^\/\\\\]+)(?:\/|$)/im';
$str = 'https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/edit#gid=123
https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/history/test1#gid=123
https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);