re = /\/d\/([^\/\\]+)(?:\/|$)/im
str = 'https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/edit#gid=123
https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be/history/test1#gid=123
https://docs.google.com/spreadsheets/d/this-is-where-the-id-would-be'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end