#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(?:[A-Z][a-zÀ-Ƶ]*){1,10}(?:\s*))+)(?:[A-Z][a-zÀ-Ƶ]*){1,10}$"
Local $sString = "John Doe Due" & @CRLF & _
"José Antonio Domínguez Cigüeña" & @CRLF & _
"Domingo Del Campo Retorno García" & @CRLF & _
"Angel Manuel Rodrígues Vermúdez"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")